Jump to content
I Forge Iron

Acid resist not working

Recommended Posts

I'm attempting to etch a pattern on the 440c. Normally with ferric chloride I use krylon spray paint and OPI nail polish as a resistant. But neither ferric chloride nor muratic acid would etch the steel.

So I tried 10:1 diluted sulfuric acid and it worked like charm. The first time I tried it got underneath the spray paint. The second time I tried using adhesive lamination film but I got the same results. 

I'm cleaning the blade with alcohol and then washing it with simple green before I put anything on it and the second attempt I re-sanded the surface down to 1000 grit. 

Anyone got any advice on what to use as a resistant?received_764415104053968.thumb.jpeg.3237c37aa9059ef17fb0adfb5e7d4407.jpeg

Link to comment
Share on other sites

2 minutes ago, ThomasPowers said:

Have you tried asphaltum varnish?

ThomasPowers. I'll be honest ive never even heard of it. Is it something you can get at a hardware store like lowes or ace?


2 minutes ago, pnut said:

Have you tried liquid paper/ White out

No I havent tried that but I do have some one hand. I'll give it a shot! 

Link to comment
Share on other sites

It's a *very* traditional acid resist; an old US government spec from 1922 said it had to resist sulfuric acid, 33%, for 6 hours...

As I recall we bought a can from an artist supply or perhaps rio grand jeweler's supply.  It was 35+ years ago when I was working with the sword maker...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...