jtspain

Blower problems?

Recommended Posts

So, I recently got an old buffalo forge as a gift, all still in working condition, well the blower lasted maybe a week before it started to get harder to crank, I let it sit for a little while and now it will not crank at all, I don't know how to disassemble it, but I feel like that's the best place to start, it's a buffalo 200 silent blower, I'm not sure if it's rust or some bolts I'm not seeing, but I can't even get the gear case off

Any and all help is appreciated, and I'm sorry if there is a more relevant thread for this question, I looked but couldn't find one

Share this post


Link to post
Share on other sites

Technicus Joe ( Joey Van Der Steeg)  has a few videos on YouTube on fixing one up. Maybe those will offer a hint of where to start. 

A good wire brushing may reveal the bolts or screws then some good soaking with penetrating oil to loosen them up. 

Share this post


Link to post
Share on other sites

Pictures please?   Is this one of the ones where the top slides till it passes the internal screws and then lifts off?  Is this one of the ones where you have to take the entire side-1/2 the case off?

Share this post


Link to post
Share on other sites
16 minutes ago, ThomasPowers said:

Pictures please?   Is this one of the ones where the top slides till it passes the internal screws and then lifts off?  Is this one of the ones where you have to take the entire side-1/2 the case off?

Im not sure and I'll send some pics tomorrow, it's too dark now

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.